PDA

View Full Version : running way to lean after installing a 16G



LewGervais
December 24th, 2006, 10:49 AM
I am driving a 1996 GST with a rebuilt 2nd generation engine. I have been running a the following upgrades until this weekend:

3" downpipe and high flow exhaust. The cat has been removed.
Front mounted inner cooler.
1st gen BOV
K&N air breather
Boost controller with a vac/boost gage
also running an air/fuel mixture gage.

The injectors and fuel pump are original as was the turbo until this past weekend. I installed the Mitsubishi 16G turbo and I noticed that the air mixture gage is showing so much of a lean mixture that the gage isn't even lighting up. I have the boost turned down to about 5-7 pounds to avoid fuel cut off problems.

All this was background and now for my question... Am I I in danger of destroying my engine if I run it like it is? Also is there anything I can do besides buying a tuning box to make the air/fuel mixture run richer? By the way my oxigen senser on the downpipe is wrapped in tim foil and strapped to the outside of the exhaust pipe. It has run like that for over a year without the CEL coming on. After installing the new turbo the light came on again. Do I need to park this car until I can install an AFC gizmo and tune it?


Lew

MiniTrucker
December 24th, 2006, 11:04 AM
By the way my oxigen senser on the downpipe is wrapped in tim foil and strapped to the outside of the exhaust pipe. It has run like that for over a year without the CEL coming on. After installing the new turbo the light came on again.


Lew



so your o2 sensor isnt in your o2 housing!!??? maybe its to early on x-mas eve and im not understanding, take some pictures of that and post them. when i first installed my 16g turbo, i was still on stock fuel system ( fuel pump, injectors, fuel pressure) and just ran like 14-16lbs of boost, that was with the smic as well.

but to answer your question, yes! its very dangerious to run your motor like that. i burnt holes in my pistons on my last motr because i leaned the a/f out to much. check your spark plugs for any signs of metal stuck to them.

LewGervais
December 24th, 2006, 11:27 AM
so your o2 sensor isnt in your o2 housing!!??? maybe its to early on x-mas eve and im not understanding, take some pictures of that and post them. when i first installed my 16g turbo, i was still on stock fuel system ( fuel pump, injectors, fuel pressure) and just ran like 14-16lbs of boost, that was with the smic as well.

but to answer your question, yes! its very dangerious to run your motor like that. i burnt holes in my pistons on my last motr because i leaned the a/f out to much. check your spark plugs for any signs of metal stuck to them.

My GST has two O2 sensors. One is in the o2 housing the second one is further down on the exhaust pipe. That is the one that is wrapped in tin foil.

LewGervais
December 24th, 2006, 11:28 AM
What is a "SMIC"?

MiniTrucker
December 24th, 2006, 11:47 AM
sorry a front mount intercooler is dubbed as "fmic"
the stock side mount intercooler is "smic"
fuel pressure regulator "fpr"
there is alot of terms that are used like that

i havent heard of someone wrapping a o2 in tin foil, the right way is to buy a o2 deleter, this plugs into were the second o2 once was and tells the computer that all is well. you can find them for $40 to $80

MiniTrucker
December 24th, 2006, 12:13 PM
heres some lean pics

Manie
December 24th, 2006, 03:26 PM
You can run the 16G with the stock injectors. Keep it at around 15 psi.
You need a fuel pump for sure.
It will run alot better with a new set of 550 injectors though.
That way you can have full benefit of the new turbo and FMIC.
And you would want a AFC from Apexi to control your fuel and get read of the fuel cut. PM me if you want. There is a local selling one for 200.00.
Your 16G will run best between 19 psi and 23 psi. Have fun.

LewGervais
December 24th, 2006, 04:12 PM
You can run the 16G with the stock injectors. Keep it at around 15 psi.
You need a fuel pump for sure.
It will run alot better with a new set of 550 injectors though.
That way you can have full benefit of the new turbo and FMIC.
And you would want a AFC from Apexi to control your fuel and get read of the fuel cut. PM me if you want. There is a local selling one for 200.00.
Your 16G will run best between 19 psi and 23 psi. Have fun.

I also just talked with someone on the phone who told me the same thing you told me that I need a new fuel pump, a Waldoro 255. I am now checking on ebay for one. Thanks for your help

DSMer
December 24th, 2006, 05:51 PM
Walbro 255lph... Do not buy one used, they are 100 brand new. You can get them new on ebay.

TrendSetter
December 28th, 2006, 11:06 AM
Walbro 255lph... Do not buy one used, they are 100 brand new. You can get them new on ebay.

http://fuel-pumps.net/walbro-forgeries.html

DSMer
December 28th, 2006, 02:26 PM
http://fuel-pumps.net/walbro-forgeries.html

Damn! I did not know... Those Bastards! Thanks for the link. Its a good, quick read.

JasonEvo8
December 29th, 2006, 03:38 PM
http://fuel-pumps.net/walbro-forgeries.html

Wow, a new low in business ethics. Amazing.